
Transformations

When building a model, it is not always easy, nor 
always desirable, to build each and every component separately, and
exactly in its final position, size, and orientation. This is where the
Transformations—Translate, Rotate, Resize, Align, Move-To, Duplicate,
Mirror—come into play; they can save you significant time and effort.
This tutorial is intended to give you a look at how each of these
transformations may be effectively used to create a basic object like a
wheel. You may later use the same techniques to construct a more
accurate wheel model, employing real-world size and proportion for a
particular type of wheel.

Double-click on the ModelPro application icon to open a New, blank
data base (or, if you are already “in” ModelPro, select New from the 
File Menu).

Setting the Preferences

Select Preferences in the Edit menu. Select
the Grid icon from the list on the right. The default is to link
the x, y, z data fields. On the Snapping Grid side of the Grid
Options, enter 0.125 in the x data field. Click on OK, or
Save Preferences to save the new grid snapping configuration.

Creating a Spoke

Select the Cylinder 3-D Primitive tool from the Tool
palette. Select the Center-to-Corner drag mode in the Draw Options
portion of the Tool palette (bottom). Click on the Grid
snap button in the Snap palette (g key). In the Top view
window, move the cursor to the center of the window,
where the origin guides cross. Click-drag diagonally until
the cursor snaps to x = 0.125 (combine what you see in the
View window with the values you see in the Status Line
palette, at the bottom of the screen, to accurately draw the
cylinder shape).

Use the Hand tool to pan the view in the Front window down until the
cylinder shape (rectangle in this view) is near the bottom of the window.
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If the cylinder is not still selected, select it using the Standard Selector
tool. In the Front View, drag the upper-right corner point of the cylinder
straight up to y = 3.25. The Grid snap should still be engaged, and will
help you once again to accurately reach the proper location.

Cloning a Second Spoke

If the cylinder is not still selected, select it using the
Standard Selector tool. Select Clone from the Edit menu (�-w) to make
a duplicate of the cylinder located directly on top of the original.

Repositioning the Second Spoke

If the cloned cylinder is not still selected, select it using
the Standard Selector tool. Select the Rotate tool from the Tool palette.
In the Rotate Tool Info palette at the top of the screen, click on the
Increment check box to engage it, and enter 30 in the data field to make
the rotation snap to a 30° angle about the Anchor. Select Galactic Core
from the Anchor pull-down menu to set the Anchor point. The Anchor
point automatically shows as a hollow, thick circle in the View windows. 

Move the cursor to the Front window and click-drag diagonally on the
upper-right corner point of the selected cylinder. The cylinder will snap
out to a 30° rotation. If you continue to drag the cylinder will snap to
60°, then to 90°, and so on. We want the 30° rotation.

Draw the cylinder and
pan Front view down

Rotate Tool

Rotate Tool Info palette
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If the cloned, rotated cylinder is not still selected, select it
using the Standard Selector tool. Select Move To in the
Operations menu (or �-m). The Move To dialog box will
appear. In the To pull-down menu, select User Offset. This
will allow you to enter a specific distance to move the selected
object. Enter x = -0.5 and z = 0.25 in their respective data
fields. Click on OK to perform the move.

Using the Selector tool, select both cylinders. Hold the Shift
key to select multiple items. Select Transform from the
Operations menu (or �-t). The Transform dialog box will
appear. The default is for all of the transform values to be zero
(no affect). In the Rotate section of the dialog box, enter 5 in
Right (y-z) data field, to give the cylinder a 5° rotation on
the x-axis. In the Center of Transform pull-down menu,
select Galactic Core. Click on OK to perform the rotation.
Save your model.

Making More Spokes

First, set a Marker at what will be the center
of the wheel. In the Front window, drag a Marker from the
upper-left corner of the Tool palette out into the window to 
x = 0, y = -1. The Grid snap should still be on to help you
accurately place the marker.

Using the Rotate tool

Move To dialog

Transform dialog
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Next, use the Shift key with the Standard Selector to select both of the
cylinders. Select Duplicate from the Edit menu (or �-=). The Duplicate
dialog box will appear. Enter 5 in the Total # data field. Select Polar

(radio button) as the Method, and Incremental (radio
button) as the Distribute. Enter 72 in the Front XY data field.
Select Marker 1 from the Center of Rotation pull-down
menu. The entries and selections you just made will cause 4
copies of the selected cylinders. Each copy will be rotated 72°
from one another, about the Marker point. Since we wanted
to make a complete circle (360°) with 5 sets of cylinders
evenly spaced, we did a little math to determine how much to
rotate each copy (360÷5=72). Click on OK to execute the
duplication.

Select all of the spokes by choosing Select All from the Edit
menu (or �-A). Select Group from the Groups menu (�-g).
Name the group “Spokes.” If the grouped spokes are not
already selected, select the group with the Standard Selector.
Choose Duplicate from the Edit menu. Enter 2 in the Total #
data field. Enter 36 in the Front XY data field. This will make
one copy of the grouped spokes and rotate that copy 36° to
fill in the larger spaces between the 2-spoke sets. Click on
OK to execute the duplication.

Setting a Marker

Duplicate dialog box

Duplicate dialog box
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Repositioning Half of the Spokes

First, set a guide line in the Top view window to indicate
the plane across which we want to mirror half of the spokes. Drag a
Guide from the ruler at the top of the window down to a position just a
hair above the spokes. Click on the Free snap button to release the 
Grid snap.

In the Groups palette, click on the folder arrow to expose the two
spokes-group folders (Spokes 1 and Spokes 2). In the Groups palette,
select one of the spokes-group folders by clicking on its name in the list
(the selected item name will be highlighted). 

Select the Mirror tool from the Tool palette. In the Mirror Tool Info
palette at the top of the screen, choose User Defined from the Anchor
point pull-down menu. In the Top window, position the cursor at the
place where the Guide you placed and x = 0 cross. Click-hold to set the
Anchor point and reflect the selected group across the Guide. Then drag
diagonally and about the Anchor point to rotate the reflected group
about 180° (in the Tool Info palette, look at the Incremental Degrees
data field to monitor the progress of rotation). Now, still holding the
mouse key down, press the Shift key to snap the rotation to exactly 180°.
Save your model.

Set the Guide

Select Spokes group

Mirror Tool

After Duplications
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Making the Hub

We want the hub to be positioned at the center of all of
the spokes (Front window), and just a bit wider than the spokes as
viewed in the Top window. Additionally, we want the hub shape to
slightly overlap the spokes to hide the bare ends of the spokes inside of
the hub.

In the Top view, set the Depth Lock at (x = 0) and at a point just below
the spokes. Now, when we draw a 2-D contour in the Front window, the
contour’s position in the Top window will be at the new Depth Lock
location rather than the default (Galactic Core).

Select the Ellipse tool from the Tool palette. In the Front view window,
position the cursor at the Marker which was set earlier. Click-drag while
holding the Shift key (constrains the ellipse to be circular).

Mirror the spokes

Ellipse Tool

Draw the hub-circle

Setting depth
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Clone the circle by choosing Clone in the Edit menu (�-w).
Select Transformations from the Operations menu (�-t).
Click on the Default Values button to reset the
transformations to zero. In the Resize section of the dialog
box, select Ratio (radio button) and Same (check box). Enter
0.5 in the x data field. Select Center Object(s) in the Center
of Transform pull-down menu. This will reduce the cloned
circle by 50% proportionally in all directions.  Click OK to
perform the transformation. 

Select both of the circles and choose Join Elements from the
Operations menu (or �-j). This brings the two elements
together in preparation to become the hub with its hole in
the center. In the Groups palette, the new 2-circle item is
named Joined Splines.

Select the Joined Splines (either with the Standard Selector or from the
Groups menu). Select the Extrude tool from the Tool palette. In the
View windows, the intuitive interface for the Extrude tool is visible. In
the Top view, pull the triangle control point, at the top-center of the
intuitive tool interface, straight down to a position just above the spokes
(hold the Shift key, so as not to angle the extrude). This positions the
opposite face of the hub. Click on the Extrude button in the Extrude
Tool Info palette to execute the extrude operation. Save your model.

Transform dialog box

Extrude Tool

Reposition Extrude tool control point After the extrude
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Making the Rim

We want the spokes and hub to be centered on the rim
as viewed in the Front window. We want the rim to be slightly wider
than the spokes at their furthest point from the center of the wheel, and
to slightly overlap the spokes so as to hide the bare ends of the spokes.

First, in the Front view pull a Guide down from the ruler at the top of
the window to a point just below the outer-most point of the spokes.
Remember, the second spoke we made is angled, and its (and its
duplicates) outer-most point is closer to the center than the outer-most
point of the straight spokes.

Select the Rounded-Rectangle tool from the Tool palette. In the Tool
Info palette, enter 0.1 in the Radius data field. This sets the corner radius
for the Rounded-Rectangle. Select the Corner-to-Corner drag mode
from the Drawing Option section of the Tool palette. Select the Grid
snap in the Snap palette. Move the cursor onto the Right view window,
and position it at the point where the Guide you just set and the y origin
line (z = 0) cross. Click-drag to z = 1.25, holding the Shift key to
constrain the rectangle to be a square.

Select both the square and the hub. Select Align from the Operations
menu. The Align dialog box will appear. Enable the Z check box, and
the Align radio button under Z. Select the Centers radio button under 
Z. This will align our rim-square to be centered on the hub, and
subsequently the hub and spokes will be centered on the rim. Click OK
to perform the align operation.

Set the Guide

Rounded-Rectangle Tool

Draw the Rectangle
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Select the rim-square. Select the Lathe tool from the Tool Info palette.
In the Lathe Tool Info palette, enter 0 in the x data field, -1 in the y data
field, and 90 in the Bank data field. This sets the center of the lathe
operation at the point where our Marker was set earlier in the tutorial,
and changes the lathe plane to the Front view.  Click Lathe in the Tool
Info palette to perform the lathe operation. In the Groups palette the
new lathed shape in named Lathe Mesh 1.

Making the Tire

First, we want to
find the center of the assembly so
that we can properly position the
tire. Select the item named
“Extrude” in the Groups palette
(this is the hub). Select Information
from the Groups menu (or �-i).
The Object/Group Information
dialog box for the selected item will
appear. In this case, the center we
are looking for happens to be the
Rotation Point of the hub. Note the
information in the x, y, and z
Rotation Point data fields.

Select the Torus 3-D Primitive tool from the Tool palette. In
the Torus Tool Info palette, enter 5.9 in the main radius data
field, and 0.65 in the minor data field. Enable the check
boxes next to the data fields to constrain the torus to these
dimensions. Consult the Reference Manual for more
information about controlling the size of a Torus. Select the
Center-to-Corner drag mode in the Draw Options portion of
the Tool palette. In the Front window, move the cursor near
the location of the Marker we set earlier in this tutorial.
Click-drag diagonally a short distance to display the torus
preview; continue dragging until the cursor is located on the Marker.
Release the mouse to set the torus in position. 

Lathe Tool

Lathe Tool Info palette

After Lathe operation

Drawing the Torus
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With the Standard Selector Tool, double-click on the torus. The
Object/Group Information dialog box will appear. Enter the x, y, and z
Rotation Point data that you noted above in the Center data fields. The
Wheel is now complete. Save your model.

Making the Wheel a Library Item

To keep our data base from growing too large, we can
create duplicate items by making the parent item a Library. Library items
do not take data space; they “point” back to the parent.

In the Groups palette, close all of the folders. Select everything by
choosing Select All in the Edit menu (or �-a). Select Group from the
Group menu and name the new group “Wheel.” This creates a single
folder containing all the parts of our wheel assembly.

Select Libraries from the Palettes sub-menu in the Windows menu. This
will expose the Libraries palette. Drag the Wheel folder from the Groups
palette to the Libraries palette. This makes Wheel a Library item and its
icon changes from a folder to a Library icon in the Groups palette. In the
Libraries palette the item appears as a folder with an on-the-fly icon of
the wheel on it.

Completed Wheel model

Libraries Palette
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Placing the Library Wheel in the Data Base

From the Libraries palette, drag the Wheel folder onto any one of the
view windows. A bounding box preview of the item appears in all of the
windows, and the Lasso tool icon temporarily changes to a Library tool
icon in the Tool palette. “Drop” the bounding box preview at a location
such that it does not overlap the parent wheel. In the Groups palette the
newly placed Library item appears, with its name
italicized. You may continue to place the wheel as
many times as you wish. When you are done, click
in an open space in the Libraries palette to disable
the Library tool.

In the Libraries palette, double-click on the Wheel
folder to expose the next lower level in its
hierarchy. If you wish, you may place these items
(and others lower in the hierarchy) in the same
fashion as outlined above. Return to higher levels
in the hierarchy by selecting the appropriate item
in the pull-down menu in the Libraries palette.
Save your model.

Now you are ready to animate, apply surface attributes, and render your
model. Select Render/Animation in the File menu to transfer to
Presenter 3.0.

Library Tool

Placing the Library item

Lower levels in the hierarchy Libraries palette pull-down menu
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Notes


